Back to overview
Degraded

Norway - Curtailment

Jan 18, 2026 at 7:16pm UTC
Affected services
Norway

Resolved
Feb 16, 2026 at 11:47am UTC

Following our earlier notifications regarding reduced work levels and ongoing curtailment, please be advised that curtailment has been lifted.
We have started the startup of the entire farm now, and ramp-up to full operation is currently in progress.
We will continue to monitor the situation and will advise if any issues arise.

Created
Jan 18, 2026 at 7:16pm UTC

Operations at the Norway mining facility have been temporarily curtailed due to elevated electricity spot prices. As a result, hashrate is currently below normal specifications. We are monitoring the energy market and will provide an update once pricing normalizes and full operations resume.