Back to overview
All Dams are offline.
Dec 19, 2025 at 2:23pm UTC
Resolved
Dec 29, 2025 at 9:37pm UTC
Outage due to blizzard conditions.
Affected services
Created
Dec 19, 2025 at 2:23pm UTC
Dams have been down since last night. Crews are investigating and working to try to restore power.
Affected services