Back to overview
Resolved
Texas - Curtailment
Jul 21, 2026 at 1:24am UTC
Affected services
Texas
Resolved
Jul 21, 2026 at 1:48am UTC
Project Dorothy is now exiting curtailment and energizing.
Affected services
Created
Jul 21, 2026 at 1:24am UTC
Dorothy_AC003: Project Dorothy has been curtailed because the nodal price at the wind farm is too high at the moment.
Affected services