Back to overview
Resolved

Texas - Curtailment

Jul 19, 2026 at 8:56pm UTC
Affected services
Texas

Resolved
Jul 19, 2026 at 11:26pm UTC

4CP Curtailment ended

Created
Jul 19, 2026 at 8:56pm UTC

Project Dorothy has been curtailed due to the requirement to draw power exclusively from the wind farm in compliance with the Utilities' Curtailment Rules [4CP or Grid Prices], but there is not enough wind at the moment.