Back to overview
Resolved

Norway - Planned Maintenance

Jul 17, 2026 at 7:00am UTC
Affected services
Norway

Resolved
Jul 17, 2026 at 10:31am UTC

Norway - [Planned Maintenance] is complete at 12:30 local time.

Created
Jul 17, 2026 at 7:00am UTC

Norway - [Planned Maintenance] - at Nothing Hill today
Estimated start time: ~09:00 (Norway time)
Estimated duration: ~1 hour