Back to overview
Resolved
South Dakota - Utility Provider Issues
Jul 10, 2026 at 3:19pm UTC
Affected services
South Dakota
Resolved
Jul 13, 2026 at 7:57am UTC
The utility provider issues have been resolved, mine is back online.
Affected services
Created
Jul 10, 2026 at 3:19pm UTC
Electric company notified about regional issues affecting the utility power lines.
Mining is currently affected and will be back up as soon as possible.
Affected services