Back to overview
Resolved
4CP 1st of the month curtailment
Jul 1, 2026 at 5:00pm UTC
Affected services
Texas
Resolved
Jul 2, 2026 at 12:00am UTC
Curtailment has finished and mining operations are gradually getting back to full capacity.
Affected services
Created
Jul 1, 2026 at 5:00pm UTC
Texas facility will be undergoing curtailment today as the first of the month on the 4CP season.
Mining operations will resume automatically once curtailment finishes.
Affected services