Back to overview
Resolved

Norway - Curtailment

Jun 26, 2026 at 10:00am UTC
Affected services
Norway

Resolved
Jun 27, 2026 at 7:05am UTC

The mine is back fully operational.

Updated
Jun 26, 2026 at 3:30pm UTC

High prices are forecasted for tomorrow (26 June 2026). To optimize costs, the operations will be reduced.

Start time: 5:30 CET
End time: 12:00 CET

Created
Jun 26, 2026 at 10:00am UTC

Production is now restored