Back to overview
Downtime
Investigating – Login Issues
Jun 20, 2026 at 8:12am UTC
Affected services
app.sazmining.com
Resolved
Jun 20, 2026 at 12:15pm UTC
Resolved – Login Issues
The login issue affecting the app has been resolved. Users should now be able to log in normally.
Thank you for your patience.
Affected services
Created
Jun 20, 2026 at 8:12am UTC
We are currently investigating an issue affecting user login on the app. Our team is actively working to resolve it.
Hashrate is not affected. This is strictly a webapp issue and mining operations are running normally.
We will provide updates as the situation progresses.
Affected services