Back to overview
Degraded
Norway - Curtailment
Jun 16, 2026 at 9:22am UTC
Affected services
Norway
Resolved
Jun 18, 2026 at 10:06am UTC
high prices are forecasted for today (18 June 2026). To optimize costs, the operations will be reduced.
Start time: 17:45 CET
End time: 18:45 CET
Affected services
Updated
Jun 17, 2026 at 10:50am UTC
Norway facility is back to mining.
Affected services
Created
Jun 16, 2026 at 9:22am UTC
High prices are forecasted for today (16 June 2026). To optimize costs, the operations will be reduced.
Affected services