Back to overview
Degraded
Norway - Annual Cooling Maintenance
Jun 10, 2026 at 8:08am UTC
Affected services
Norway
Resolved
Jun 11, 2026 at 11:06am UTC
Maintenance finished and mine is back online.
Affected services
Created
Jun 10, 2026 at 8:08am UTC
Annual cooling maintenance is being performed at Nothing Hill during today (10 June).
Expect intermittent shutdowns through the day; machines will go off and back on periodically, with no fixed timing. We'll keep you posted and minimize disruption.
Affected services