Norway - Curtailment
Resolved
May 18, 2026 at 10:30am UTC
Today (17 May 2026) high prices are forecasted. To optimize costs, we plan to reduce operations during the day.
Start time: 7:00 AM
End times and the expected duration will be confirmed during the day once final prices and conditions are clearer.
We will monitor the market closely and provide real-time updates.
Thank you for your attention to this matter!
Affected services
Created
May 6, 2026 at 2:30am UTC
Today (06 May 2026) high prices are forecasted. To optimize costs, we plan to reduce operations during the day.
Start time: 4:30 AM
End times and the expected duration will be confirmed during the day once final prices and conditions are clearer.
We will monitor the market closely and provide real-time updates.
Thank you for your attention to this matter.
Affected services