Back to overview
Degraded

Regional Outage - Ethiopia VPS Region

Mar 2, 2026 at 5:30am UTC
Affected services
Ethiopia

Resolved
Mar 2, 2026 at 5:06pm UTC

Mining operations have been routed through another region with stable connection.

All Virtual Rigs should be sending hashrate again, please contact your CSA if you notice any unusual behaviour.

Created
Mar 2, 2026 at 5:30am UTC

We are experiencing connectivity issues between Virtual Rigs and the Pool due to regional infrastructure problems affecting our VPS provider in Ethiopia. This may result in interrupted mining operations, reduced hash rate reporting or temporary disconnections from the pool.

Our engineering team is actively working with our VPS provider to resolve the regional issue and restore full connectivity. We are monitoring the situation in real-time and will deploy alternative routing if necessary.

We sincerely apologize for any impact on your operations and appreciate your patience as we work toward a swift resolution.