Back to overview
Degraded
Norway - Curtailment
Feb 17, 2026 at 10:39am UTC
Affected services
Norway
Resolved
Feb 25, 2026 at 12:39pm UTC
Mine back to normal operations.
Affected services
Created
Feb 17, 2026 at 10:39am UTC
High prices forecasted in Norway. Operations reduced.
Affected services