Back to overview

Scheduled Maintenance

Sep 08 at 07:30am EDT
Affected services
Norway

Resolved
Sep 08 at 09:57am EDT

All miners are now back online and operating normally. Monitoring shows stable performance across the fleet

Created
Sep 08 at 07:30am EDT

The downtime is due to a small adjustment that needs to be carried out on-site. The interruption is expected to start around 13:30 today and should last approximately 30 minutes in total.

Thank you for your understanding.