Back to overview
Paraguay site is currently down
Aug 14 at 06:03am EDT
Affected services
Paraguay Air
Paraguay Hydro
Resolved
Aug 14 at 06:03am EDT
There has been an interruption in the ANDE transmission line
Affected services
Resolved
Aug 14 at 06:03am EDT
There has been an interruption in the ANDE transmission line
Affected services