Back to overview
Degraded
Low River Flow, reduced power generation - 20% curtailment
May 21 at 05:49pm EDT
Affected services
Wisconsin
Resolved
Jun 24 at 12:30pm EDT
Water flow back to normal state. No curtailment.
Affected services
Wisconsin
Created
May 21 at 05:49pm EDT
Low River Flow, reduced power generation - 20% curtailment. Curtailment will be rolled across the facility in 24 hour intervals, to share the curtailment across all rigs.
Affected services
Wisconsin