Back to overview
Downtime
Hydro-power dams are offline - Data Center is offline
May 17 at 11:45am EDT
Affected services
Wisconsin
Resolved
May 17 at 01:27pm EDT
Dams are back online. The data center is 100% online and hashing.
Affected services
Wisconsin
Created
May 17 at 11:45am EDT
The dam system is experiencing an outage. Operators are diagnosing and working to get power generation back up.
Affected services
Wisconsin