Back to overview
Degraded

Norway - Controlled shutdown. Skids Maintenance.

May 14 at 07:32am EDT
Affected services
Norway

Resolved
May 14 at 10:03am EDT

Mine is back fully operational.

Created
May 14 at 07:32am EDT

There will be a controlled shutdown now, this is due to a maintenance of Skids. Mine should be up and running again soon.