Back to overview
Degraded
Norway - Temporary Issues
May 12, 2025 at 3:02pm UTC
Affected services
Norway
Resolved
May 13, 2025 at 10:15am UTC
Full mine is back hashing as expected.
Affected services
Created
May 12, 2025 at 3:02pm UTC
Part of the fleet is affected by temporary issues.
Affected services