Back to overview
Resolved
Texas - Curtailment
Sep 19, 2026 at 9:48pm UTC
Affected services
Texas
Resolved
Sep 20, 2026 at 12:33am UTC
The Texas site is now exiting curtailment and energizing.
Affected services
Created
Sep 19, 2026 at 9:48pm UTC
The Texas site has been curtailed because the regional price is too high at the moment.
Affected services