Back to overview
Resolved

Texas - Curtailment

Sep 18, 2026 at 1:19am UTC
Affected services
Texas

Resolved
Sep 18, 2026 at 1:29am UTC

The Texas site is now exiting curtailment and energizing.

Created
Sep 18, 2026 at 1:19am UTC

The Texas site has been curtailed because the nodal price at the wind farm is too high at the moment.