Back to overview
Resolved

Norway - Curtailment

Sep 14, 2026 at 6:00am UTC
Affected services
Norway

Resolved
Sep 15, 2026 at 7:00am UTC

Іnform you that electricity prices have dropped and we've launched the miners. Miners are now reaching their target capacity.

Created
Sep 14, 2026 at 6:00am UTC

Operations are temporarily reduced due to high electricity prices.

Start time: 08:00 CEST