Back to overview
Resolved

Norway - Curtailment

Sep 8, 2026 at 1:30pm UTC
Affected services
Norway

Resolved
Sep 10, 2026 at 8:27am UTC

All rigs are powering back up after curtailment.

Created
Sep 8, 2026 at 1:30pm UTC

Please note that high prices are forecasted for today (08 September 2026). To optimize costs, the operations will be reduced.

Start time: 15:30 CET