Back to overview
Resolved
Norway - Curtailment
Sep 7, 2026 at 3:45am UTC
Affected services
Norway
Resolved
Sep 7, 2026 at 5:30am UTC
Please note that high prices are forecasted for tomorrow (7 September 2026). To optimize costs, the operations will be reduced.
Start time: 5:45 CET
End time: 7:30 CET
Affected services
Created
Sep 7, 2026 at 3:45am UTC
Please note that high prices are forecasted for tomorrow (7 September 2026). To optimize costs, the operations will be reduced.
Start time: 5:45 CET
End time: 7:30 CET
Affected services