Back to overview
Resolved

Norway - Curtailment

Sep 1, 2026 at 4:00am UTC
Affected services
Norway

Resolved
Sep 1, 2026 at 12:00pm UTC

Please note that high prices are forecasted for tomorrow (1 September 2026). To optimize costs, we plan to reduce operations during the following periods (local time):

6:15 — 10:15
10:45 — 11:00
11:45 — 12:15
12:45 — 13:45

Created
Sep 1, 2026 at 4:00am UTC

Please note that high prices are forecasted for tomorrow (1 September 2026). To optimize costs, we plan to reduce operations during the following periods (local time):

6:15 — 10:15
10:45 — 11:00
11:45 — 12:15
12:45 — 13:45