Back to overview
Resolved

Paraguay - Maintenance

Aug 24, 2026 at 10:56am UTC
Affected services
Paraguay Air
Paraguay Hydro

Resolved
Aug 24, 2026 at 3:13pm UTC

The modulation event, which began at 07:56 hours (GMT -3), ended at 12:13 hours (GMT -3) and lasted 4 hours and 17 minutes.

Created
Aug 24, 2026 at 10:56am UTC

The modulation event, which began at 07:56 hours (GMT -3), ended at 12:13 hours (GMT -3) and lasted 4 hours and 17 minutes.