Back to overview
Resolved

Texas - Curtailment

Aug 18, 2026 at 12:04am UTC
Affected services
Texas

Resolved
Aug 18, 2026 at 2:34am UTC

Dorothy_EC007: Project Dorothy is now exiting curtailment and energizing.

Created
Aug 18, 2026 at 12:04am UTC

Dorothy_AC005: Project Dorothy has been curtailed because the regional price is too high at the moment.