Back to overview
Resolved

Norway - Curtailment

Aug 18, 2026 at 11:32am UTC
Affected services
Norway

Resolved
Aug 22, 2026 at 3:51pm UTC

The site is currently operating at full capacity

Created
Aug 18, 2026 at 11:32am UTC

Operations are reduced due to high prices